Debrandowanie e5573-320

Kwestie techniczne, konfiguracja i rozwiązywanie problemów z modemami GSM (GPRS, EDGE, UMTS, HSDPA i HSUPA).

Moderator: Moderatorzy

dzejk
Guru bezprzewodowy
Posty: 6786
Rejestracja: 2014-10-17, 14:37
Lokalizacja: internet

Re: Debrandowanie e5573-320

Postautor: dzejk » 2019-12-26, 17:13

jest prosty skrypt do odblokowania portów http://www.mediafire.com/file/jexg56a7n ... y.zip/file
TP-LINK TL-WR1043NDv2 @ LuCI openwrt + Huawei e3372s-153 hilink mod
Pliki dla Huawei https://www.mediafire.com/folder/ll9ieqqooyhy5/Documents

pkob86
Początkujący użytkownik forum
Posty: 13
Rejestracja: 2016-02-15, 22:02

Re: Debrandowanie e5573-320

Postautor: pkob86 » 2019-12-26, 17:20

udało sie. co za modem, jeszcze tylko jezyk polski

badziewmax
Początkujący użytkownik forum
Posty: 10
Rejestracja: 2011-01-04, 14:03
Lokalizacja: Pe do En i kreska

Re: Debrandowanie e5573-320

Postautor: badziewmax » 2020-01-11, 16:56

Witam,

Pacjent: E5573s-320

1. Boot z igły
2. Wgranie usblsafe-5573bs.bin
3. Po restarcie modemu uruchamiam P711s-E5_Update_21.110.99.02.00.exe
4. Błąd: Kod Błędu 13 aktualizacja nie powidodła się

Wersja oprogramowania: 21.200.11.00.264
WEBUI: WEBUI_17.100.11.00.264

Proszę o podpowiedź co zrobić w tej sytuacji.

dzejk
Guru bezprzewodowy
Posty: 6786
Rejestracja: 2014-10-17, 14:37
Lokalizacja: internet

Re: Debrandowanie e5573-320

Postautor: dzejk » 2020-01-11, 22:21

zamiast usblsafe i softu przejściowego możesz użyć komendy AT^SFM=1
poszukaj szczegółów na forum
TP-LINK TL-WR1043NDv2 @ LuCI openwrt + Huawei e3372s-153 hilink mod
Pliki dla Huawei https://www.mediafire.com/folder/ll9ieqqooyhy5/Documents

badziewmax
Początkujący użytkownik forum
Posty: 10
Rejestracja: 2011-01-04, 14:03
Lokalizacja: Pe do En i kreska

Re: Debrandowanie e5573-320

Postautor: badziewmax » 2020-01-12, 21:52

dzejk pisze:zamiast usblsafe i softu przejściowego możesz użyć komendy AT^SFM=1
poszukaj szczegółów na forum


Niestety nijak nie mogę zmusić DC Unlocker do wykrycia modemu :/ W tej chwili modem wstaje albo po igle albo jako ADB device, co też jakoś średnio działa, bo w Manadżerze Urządzeń mam błąd Nie można uruchomić tego urządzenia. (Kod 10) The USB device returned an invalid product description string descriptor.

dzejk
Guru bezprzewodowy
Posty: 6786
Rejestracja: 2014-10-17, 14:37
Lokalizacja: internet

Re: Debrandowanie e5573-320

Postautor: dzejk » 2020-01-13, 19:34

a jak dasz iglę, usblsafe i od razu soft modowany?
TP-LINK TL-WR1043NDv2 @ LuCI openwrt + Huawei e3372s-153 hilink mod
Pliki dla Huawei https://www.mediafire.com/folder/ll9ieqqooyhy5/Documents

badziewmax
Początkujący użytkownik forum
Posty: 10
Rejestracja: 2011-01-04, 14:03
Lokalizacja: Pe do En i kreska

Re: Debrandowanie e5573-320

Postautor: badziewmax » 2020-01-13, 22:18

Wtedy jest tak:
1. Boot z igły
2. Wgranie usblsafe-5573bs.bin
3. Po restarcie modemu uruchamiam E5573_Update_21.316.03.00.143_M_AT_04.01.exe

Na kroku "Rozpocznij przywracanie informacji użytkownika" modem się chyba restartuje i uruchamia w trybie ADB (z błędem jak wyżej) i Kodem 21 z błędem przywracania informacji.

dzejk
Guru bezprzewodowy
Posty: 6786
Rejestracja: 2014-10-17, 14:37
Lokalizacja: internet

Re: Debrandowanie e5573-320

Postautor: dzejk » 2020-01-14, 00:04

pozostaje czyszczenie pamięci, jak w instrukcji modem2.pdf dla e3372h. Oczywiście podmieniasz pliki od e5573.
TP-LINK TL-WR1043NDv2 @ LuCI openwrt + Huawei e3372s-153 hilink mod
Pliki dla Huawei https://www.mediafire.com/folder/ll9ieqqooyhy5/Documents

badziewmax
Początkujący użytkownik forum
Posty: 10
Rejestracja: 2011-01-04, 14:03
Lokalizacja: Pe do En i kreska

Re: Debrandowanie e5573-320

Postautor: badziewmax » 2020-01-14, 00:18

Enable erase of (pseudo) bed blocks ?
1 - no
2 - yes
0 - exit
: 2

> balong_usbdload -b -t ptable-hilink.bin -s4 -s14 -s16 usblsafe-3372h.bin

????????? USB-????????? Balong-???????, ?????? 2.02, (c) forth32, 2015
???? ??? Windows 32bit (c) rust3028, 2016

* ??????? ????????? flash_eraseal ?? ???????? 00000460

????? ?????...
????: COM6


????????? ????? ?????? %????????
------------------------------------------
raminit 00000000 3412 100%
usbboot 57900000 215224 100%

???????? ????????

Wait for the device override and press Enter

> fastboot -i0x12d1 getvar product
< waiting for device >

Oczywiście się nie doczeka, bo... urządzenie ADB zwraca (Kod 10) The USB device returned an invalid product description string descriptor.
Jutro spróbuję na innym PC.
usblsafe-3372h.bin podmieniony na "mój".

Crocodilek
Początkujący użytkownik forum
Posty: 6
Rejestracja: 2017-10-03, 12:54

Re: Debrandowanie e5573-320

Postautor: Crocodilek » 2020-01-15, 22:32

Witam :)

Posiadam router MiFi Huawei E5573 pochodzący z sieci Beeline (E5573Bs-320). Nic w nim nie zmieniałem, soft wygląda na niebrandowany i jest w wersjach:

* Firmware: 21.200.07.00.00
* WEBUI: 17.100.08.01.983

Chciałbym zaktualizować go do najnowszych / najlepszych wersji. Śledząc forum starałem się dojść do tego co należy zrobić, nieocenione przy tym okazały się zwłaszcza posty od dzejka oraz Jego repozytorium (ogromne podziękowania!).

Nie jestem mimo wszystko tak mocno w temacie, dlatego chciałbym poprosić Was o potwierdzenie że takie kroki są właściwe:

1. Instalacja wymaganych sterowników:
  • MobileBrServ_22.001.26.01.03.zip
  • HUAWEI_DataCard_Driver_6.00.08.00_Setup.rar
  • FC_SeriaI_Driver_Setup.7z

2. Instalacja poprawki dla Windows 10 (BOS_solution_2.rar) lub programu Huawei Mobile Partner (Mobile_partner_win10.zip):

3. Odblokowanie routera poleceniami w DC-unlocker:

Kod: Zaznacz cały

AT^SFM=1

OK

AT^NVWREX=8268,0,12,1,0,0,0,2,0,0,0,A,0,0,0

OK

AT^SFM=0


oraz restart.

4. Instalacja firmware (E5573s-320_Update_21.329.01.00.00_M_AT_04.10.rar) oraz restart

5. Instalacja WEBUI (WEBUI_17.100.18.03.143_HILINK_Mod1.21.zip) oraz restart

6. (Opcjonalnie) Instalacja języka polskiego (e5573s-320_jezyk_polski.zip)

Dodatkowo nie mam pewności co do wyboru konkretnych wersji. O ile najnowszy modowany firmware wydaje się dobrym wyborem (nie znalazłem żadnych jego minusów), o tyle nie wiem którą wersję WEBUI użyć. Najnowsza wersja w katalogu E5573 to E5573_Update_WEBUI_17.100.11.00.03_Mod1.6.rar, a najnowsza ogólnie to wymieniony wcześniej Mod1.21 z katalogu E327x. Na 4PDA widziałem komentarze że nie koniecznie najnowsza wersja jest najlepsza oraz że 1.21 wymaga jakiejś poprawki przywracającej "Restore button" (nie wiem co to za przycisk). Jest jeszcze Mod1.20, który jest dostępny znacznie dłużej i nie natknąłem się na żądne negatywne opinie o nim...

Będę ogromnie wdzęczny za wszelkie wskazówki :)

Pozdrawiam,
Crocodil

dzejk
Guru bezprzewodowy
Posty: 6786
Rejestracja: 2014-10-17, 14:37
Lokalizacja: internet

Re: Debrandowanie e5573-320

Postautor: dzejk » 2020-01-18, 16:17

modowane firmware i webui instalujesz po sfm=1, a przed powrotem do sfm=0. Na początek użyj webui z folderu e5573. Dopiero potem eksperymentuj, jak chcesz.
TP-LINK TL-WR1043NDv2 @ LuCI openwrt + Huawei e3372s-153 hilink mod
Pliki dla Huawei https://www.mediafire.com/folder/ll9ieqqooyhy5/Documents

Crocodilek
Początkujący użytkownik forum
Posty: 6
Rejestracja: 2017-10-03, 12:54

Re: Debrandowanie e5573-320

Postautor: Crocodilek » 2020-01-18, 21:55

@dzejk: Super, dziękuję Ci bardzo :-) Tak zrobię :-)

Crocodilek
Początkujący użytkownik forum
Posty: 6
Rejestracja: 2017-10-03, 12:54

Re: Debrandowanie e5573-320

Postautor: Crocodilek » 2020-01-20, 14:50

Aktualizacja: (Prawie) Wszystko zadziałało :)

Kroki które musiałem wykonać okazały się odrobinę inne niż to co opisałem:

1. Instalacja wszystkich 3 sterowników. Poprawki do Windowsa nie zainstalowałem, ponieważ o niej zapomniałem ale na szczęście nie okazała się konieczna.

2. Uruchomienie DC-unlocker, połączenie z modemem ("lupa"), wpisanie:

Kod: Zaznacz cały

AT^SFM=1

OK


oraz instalacja najnowszego firmware (świeżutkie E5573Bs-320_Update_21.333.63.00.67_M_AT_04.10.rar). Po instalacji modem zrestartował się i nie był widoczny ani przez przeglądarkę, ani przez DC-unlocker.

3. Odpięcie i restart modemu. Restart DC-unlocker, ponowne podpięcie modemu i połączenie się z nim. Nie wiem czy było to konieczne ale jeszcze raz wpisałem:

Kod: Zaznacz cały

AT^SFM=1

OK


Następnie zainstalowałem WEBUI w wersji Mod1.6 (E5573_Update_WEBUI_17.100.11.00.03_Mod1.6.rar). Ponownie modem sam się zrestartował.

4. Restart i odpięcie modemu, restart dc-unlocker, ponowne podpięcie i połączenie. Komenda:

Kod: Zaznacz cały

AT^SFM=0

OK


Sprawdziłem że nowy firmware i WEBUI wgrały się poprawnie i działają.


Później w podobny sposób wgrałem jeszcze najnowsze WEBUI (Mod1.21). Okazało się, że ma mocno zmienioną szatę graficzną, co nie przypadło mi do gustu, więc spróbowałem jeszcze wgrać Mod1.20. Niestety mimo komunikatu o powodzeniu, modem przestał się uruchamiać - migały wszystkie 3 diody. Być może ma to coś wspólnego z faktem że Mod1.21 ma rozmiar około 29MB, kiedy Mod1.20 ma aż 35MB.

Udało mi się powrócić do Mod1.21 i przy tym pozostanę :)

Crocodilek
Początkujący użytkownik forum
Posty: 6
Rejestracja: 2017-10-03, 12:54

Re: Debrandowanie e5573-320

Postautor: Crocodilek » 2020-01-21, 14:20

Aktualizacja 2:

Być może jest to powszechnie znane ale okazuje się że wygląd WEBUI można zmodyfikować w ustawieniach moda, dostępne są 3 opcje:
  • MTS (MTC) - domyślny czerwony wygląd oparty na kolorystyce rosyjskiej sieci komórkowej
  • Huawei - tradycyjny wygląd WEBUI
  • Bootstrap - wygląd oparty na bibliotece Bootstrap

Okazuje się, że problem z "restore button" o którym pisałem wcześniej, to po prostu drobny błąd polegający na braku przycisku do przywracania fabrycznych ustawień. W repozytorium @dzejk nie ma odpowiedniej poprawki ale na szczęście odpowiedni skrypt można znaleźć na 4PDA: button_restore.zip

badziewmax
Początkujący użytkownik forum
Posty: 10
Rejestracja: 2011-01-04, 14:03
Lokalizacja: Pe do En i kreska

Re: Debrandowanie e5573-320

Postautor: badziewmax » 2020-01-23, 22:56

Niestety nadal nie mogę dojść z tym urządzeniem do ładu.

Udało mi się skombinować laptopa z Windows 7 gdzie wszystkie sterowniki są poprawnie zainstalowane, a w Device Manager widać, że wszystko się
zgłasza zgodnie z tym co wyczytałem w wątku.

Działa czyszczenie pamięci z modem2.pdf, zakończyłem cały proces.
Soft przejściowy: błąd jak wcześniej
Soft modowany: jak wcześniej, błąd przywracania danych użytkownika

DC-unlocker nie widzi modemu (Select model na Auto) ani po starcie z igły, ani po wgraniu poprawnego bootloadera.


Wróć do „Modemy GSM”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 5 gości